Google идет по стопам Apple, когда дело доходит до циклов обновления программного обеспечения и приложений. Гигант ранее избавил App Store приложений, которые не поддерживают новейшие модели iPhone и тепер Google делает шаг, который может иметь такое же влияние.

В декабре прошлого года гигант Mountain View объявил о внедрении новых требований к приложениям для Android. Часть из них требует от разработчиков обеспечения того, чтобы их приложения в Play Store должны были ориентироваться на уровень API не более чем на один год старше текущей версии. Согласно Android Police, это означало бы, что приложения, представленные в Play Store после выпуска Android P, должны быть нацелены на Android 8.0 Oreo или выше.

Компания Google недавно также подтвердила, что будущие версии операционной системы Android будут блокировать приложения, которые не смогут настроить таргетинг на последний уровень AP.